کامپیوتر، مهندسی ۴۴۷ بازدید

نرم افزار Cisco Packet Tracer یک ابزار شبیه‌سازی بصری چند پلتفرمی است که از سوی شرکت «سیسکو سیستمز» (Cisco Systems) ارائه شده و به کاربران امکان می‌دهد که توپولوژی‌های شبکه را ایجاد کرده و شبکه‌های مدرن رایانه‌ای را تقلید نمایند. این نرم‌افزار به کاربران اجازه می‌دهد که پیکربندی روترها و سوئیچ‌های سیسکو را با استفاده از یک رابط خط فرمان شبیه‌سازی کنند. ما در این نوشته به توضیح کارکردهای این نرم‌افزار و همچنین روش راه اندازی Voip در Packet Tracer می‌پردازیم.

Packet Tracer از یک رابط «کشیدن و رها کردن» بهره می‌گیرد که موجب می‌شود کاربران بتوانند دستگاه‌های شبیه‌سازی‌شده شبکه را بسته به نیاز اضافه یا حذف کنند. این نرم‌افزار به طور عمده روی دانشجویان آکادمی Certified Cisco Network Associate تمرکز دارد و به عنوان یک ابزار آموزشی به ایشان کمک می‌کند تا مفاهیم بنیادی CCNA را بیاموزند.

آشنایی مختصر با Packet Tracer

نرم‌افزار Packet Tracer را می‌توان در محیط‌های لینوکس، ویندوز و مک اجرا کرد. اپلیکیشن‌هایی برای سیستم‌های اندروید و iOS نیز عرضه شده‌اند. Packet Tracer به کاربران امکان می‌دهد که توپولوژی‌های شبیه‌سازی شده شبکه را از طریق کشیدن و رها کردن روترها، سوئیچ‌ها و دیگر انواع دستگاه‌های شبکه ایجاد کنند. یک اتصال فیزیکی بین دستگاه به وسیله آیتم Cable نمایش می‌یابد. همچنین پاکت تریسر از گونه‌های مختلفی از پروتکل‌های لایه اپلیکیشن، مسیریابی ابتدایی با RIP، OSPF، EIGRP و BGP پشتیبانی می‌کند.

Packet Tracer علاوه بر جنبه‌های مختلف شبکه‌های کامپیوتری، می‌تواند برای همکاری روی پروژه‌ها نیز مورد استفاده قرار گیرد. این نرم‌افزار از نسخه 5.0 به بعد از سیستم چندکاربره پشتیبانی می‌کند که به کاربران امکان می‌دهد تا چند توپولوژی مختلف را روی یک شبکه کامپیوتری متصل نمایند.

راه اندازی Voip در Packet Tracer

توضیح روش راه اندازی Voip در Packet Tracer را با ارائه یک تعریف کلی از فناوری Voip آغاز می‌کنیم. Voip اختصاری برای عبارت «صدا روی IP» (Voice over IP) است. در واقع هر چیزی که امکان ارسال صدا روی اینترنت را فراهم سازد، Voip نامیده می‌شود.

شرکت‌های زیادی وجود دارند که خدمات Voip را ارائه می‌کنند، اما ما در این راهنما روی سرویس‌های شرکت سیسکو تمرکز داریم و روش پیکربندی این سرویس را روی Packet Tracer 7.3 بررسی می‌کنیم. شبکه‌ای که روی آن کار می‌کنیم به صورت زیر است.

نمودار شبکه

راه‌اندازی Voip در Packet Tracer

پیکربندی اینترفیس FastEthernet 0/0 و سرور DHCP روی روتر A

ابتدا اینترفیس FastEthernet 0/0 را با نشانی آی پی 192.168.10.1/24 پیکربندی می‌کنیم. فراموش نکنید که اینترفیس را بدون فرمان shutdown فعال کنید.

RouterA>enable
RouterA#configure terminal
RouterA(config)#interface FastEthernet0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#no shutdown

سرور DHCP برای ارائه هر تلفن IP که باید به شبکه وصل شود لازم است و باید نشانی IP و مکان سرور TFTP نیز ارائه شود.

RouterA(config)#ip dhcp pool VOICE #Create DHCP pool named VOICE
RouterA(dhcp-config)#network 192.168.10.0 255.255.255.0 #DHCP network network 192.168.10 with /24 mask#
RouterA(dhcp-config)#default-router 192.168.10.1 #The default router IP address#
RouterA(dhcp-config)#option 150 ip 192.168.10.1 #Mandatory for voip configuration.

پس از پیکربندی روتر ISR باید لحظه‌ای مکث کرده و کرسر ماوس را روی گوشی ببرید تا با ظاهر شدن خلاصه اطلاعات پیکربندی، بررسی کنید آیا IP Phone 1 نشانی آی‌پی را برداشته است یا نه.

پیکربندی سرویس Call Manager Express telephony روی روتر A

اکنون باید سرویس Call Manager Express telephony را روی روتر A فعال کنیم تا بتوانیم از خدمات Voip روی شبکه استفاده کنیم.

RouterA(config)#telephony-service #Configuring the router for telephony services#
RouterA(config-telephony)#max-dn 5 #Define the maximum number of directory numbers#
RouterA(config-telephony)#max-ephones 5 #Define the maximum number of phones#
RouterA(config-telephony)#ip source-address 192.168.10.1 port 2000 #IP Address source#
RouterA(config-telephony)#auto assign 4 to 6 #Automatically assigning ext numbers to buttons#
RouterA(config-telephony)#auto assign 1 to 5 #Automatically assigning ext numbers to buttons#

پیکربندی voice vlan روی سوئیچ A

پیکربندی زیر را روی اینترفیس‌های سوئیچ A به کار بگیرید. این پیکربندی ترافیک داده و صدا را روی vlan-های مختلف روی سوئیچ A تقسیم می‌کند. بسته‌های داده روی access vlan حمل می‌شوند.

SwitchA(config)#interface range fa0/1 – 5 #Configure interface range#
SwitchA(config-if-range)#switchport mode access
SwitchA(config-if-range)#switchport voice vlan 1 #Define the VLAN on which voice packets will be handled#

پیکربندی دایرکتوری گوشی روی IP Phone 1

با این که IP Phone 1 هم اینک به SwitchA وصل شده است، به یک پیکربندی اضافی هم نیاز دارد تا بتواند ارتباط برقرار کند. شما باید RouterA CME را نیز پیکربندی کنید تا شماره تلفن به این نشانی IP نسبت داده شود.

RouterA(config)#ephone-dn 1 #Defining the first directory entry#
RouterA(config-ephone-dn)#number 54001 #Assign the phone number to this entry#

تأیید پیکربندی

مطمئن شوید که IP Phone یک نشانی IP و یک شماره تلفن 54001 از روتر A دریافت می‌کند (البته ممکن است کمی طول بکشد).

پیکربندی دایرکتوری گوشی برای IP Phone 2

IP Phone 2 را به سوئیچ A وصل کرده و گوشی را با استفاده از آداپتر برق روشن کنید.

RouterA(config)#ephone-dn 2 #Defining the first directory entry#
RouterA(config-ephone-dn)#number 54002 #Assign the phone number to this entry#

تأیید پیکربندی

مطمئن شوید که IP Phone 2 یک نشانی آی‌پی و شماره تلفن 54002 را از روتر ‌َ A دریافت می‌کند. شماره 54001 را بگیرید و مطمئن شوید که IP phone 1 به درستی تماس را دریافت می‌کند.

سخن پایانی

Packet Tracer یک نرم‌افزار آموزشی است که از سوی سیسکو سیستمز برای آموزش دانشجویان و کمک به طراحی شبکه‌های پیچیده و بزرگ ارائه شده است. طراحی این نوع شبکه‌ها غالباً به صورت فیزیکی بسیار پرهزینه است و به این ترتیب این نرم‌افزار امکان آموزش صحیح‌تر و مؤثر را فراهم ساخته است. در این مطلب با روش راه اندازی Voip در Packet Tracer آشنا شدیم.

اگر این مطلب برای شما مفید بوده است، آموزش‌ها و مطالب زیر نیز به شما پیشنهاد می‌شوند:

بر اساس رای ۰ نفر
آیا این مطلب برای شما مفید بود؟
شما قبلا رای داده‌اید!
اگر بازخوردی درباره این مطلب دارید یا پرسشی دارید که بدون پاسخ مانده است، آن را از طریق بخش نظرات مطرح کنید.

«میثم لطفی» در رشته‌های ریاضیات کاربردی و مهندسی کامپیوتر به تحصیل پرداخته و شیفته فناوری است. وی در حال حاضر علاوه بر پیگیری علاقه‌مندی‌هایش در رشته‌های برنامه‌نویسی، کپی‌رایتینگ و محتوای چندرسانه‌ای، در زمینه نگارش مقالاتی با محوریت نرم‌افزار با مجله فرادرس همکاری دارد.

نظر شما چیست؟

نشانی ایمیل شما منتشر نخواهد شد.

مشاهده بیشتر